Вы еще используете PHP.5.4 ? Тогда поосторожнее с mb_internal_encoding()

Не всегда есть возможность использовать последнюю (или ту, какую хочешь) версию PHP. Один случай (все более редкий) — ваш хостинг-провайдер еще не завез новой версии PHP. Второй — в компании вы работаете на «сертифицированной» *nix системе (например, Oracle Linux Enterprise), и ваш работодатель/админ не планирует в ближайшем будущем менять ее версию. А самовольный upgrade до актуальных версий нарушает статус «сертифицированной» ОС.
В итоге вы сидите на PHP 5.4.

Читать далее «Вы еще используете PHP.5.4 ? Тогда поосторожнее с mb_internal_encoding()»